Instalar o actualizar PHP 5.5 en CentOS 7

Hoy trabajamos con ambientes de desarrollo. En la versión 7 de CentOS, en este momento la versión de PHP que se instala con YUM es la 5.4.16

# php -v
PHP 5.4.16 (cli) (built: Jun 23 2015 21:17:27) 
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies

Para instalar siempre con YUM la versión 5.5 de PHP (requerida por phpmyadmin, por ejemplo) podemos usar el repositorio REMI.

wget http://rpms.famillecollet.com/enterprise/remi-release-7.rpm
rpm -Uvh remi-release-7*.rpm

Una vez "instalado" debemos habilitar el repositorio de la versión php que se necesite (en mi caso, 5.5). Editar entonces el archivo /etc/yum.repos.d/remi.repo

[remi-php55]
name=Remi's PHP 5.5 RPM repository for Enterprise Linux 7 - $basearch
#baseurl=http://rpms.remirepo.net/enterprise/7/php55/$basearch/
mirrorlist=http://rpms.remirepo.net/enterprise/7/php55/mirror
# NOTICE: common dependencies are in "remi-safe"
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

Actualizar los paquetes de PHP

yum update php